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Creating a menu 5

Creating a menu

Xway can be used to create navigation menus that are replaced by hamburger 
menus on devices with small screens. A hamburger menu is a drop-down 
menu that appears when the user clicks or taps on a hamburger icon (so-called 
because it normally contains three horizontal bars that resemble a hamburger). 

This is the second in a series of Xway tutorials, following the Xway Tutorial, 
which provides a general introduction to Xway.

This chapter provides a step-by-step tutorial for creating a navigation menu. 
The next chapter contains instructions for adding this menu to the Ambient 
and Ambient Light documents that are created by the Xway Tutorial.

Note: This tutorial has been updated for Xway 1.1. If you are using an earlier version 
of Xway, please update to the latest version. Click on About Xway (in the Xway 
menu) if you are not sure which version of Xway you are using.

Preliminaries

Start by creating a new document. This initially contains a single site page 
(Page 1) and a single master page (Master 1).

Click in the Title field in the Page section of the Page Inspector, and set the 
page title to Home, then press Return. Add another page by choosing Page 
from the Insert menu, and type News in the Page Title field. Then add three 
more pages, titled About, Gallery, and Contact.

Adding a menu

The next step is to add a menu at the top of the master page. We could add it 
separately on each of the site pages, but it’s much less work if we add it on a 
master page.

Go to the master page (click on it in the Site panel) and add a menu by 
choosing Menu from the Insert menu. This adds a menu containing four menu 
items. We have five site pages that we want to link to, so add a further item by 
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selecting one of the existing items and duplicating it (choose Duplicate 
Selection from the Edit menu).

Editing menu items

We now have a menu box with five menu items, and we want to change the 
text in each menu item so that it identifies the pages that we will link to.

Double-click on the first menu item to edit it (or select it and press Command-
Return). Change the text to Home, the title of the first site page. Then use the 
Tab key to switch to the second menu item and type News. Continue in the 
same way until you have five menu items named Home, News, About, Gallery, 
and Contact.

Adding links

The next step is to add some links.

Select the first menu item by clicking on it (it doesn’t matter if there is a text 
selection or not) and choose Link from the Format menu. Select Home from the 
Page popup and OK the dialog. Then tab to the next item and link it to the 
News page. Continue until you have linked all the items.

Adding content

Before we test the menu, it would be helpful to have some distinct content on 
each page, so we can see that the links work correctly. We also want to add 
additional content so that we can see how the menu behaves when a page is 
scrolled.

Add a box to the master page, just below the menu: select the menu box (the 
parent box that contains the individual menu items), then choose Box from the 
Insert menu or toolbar. When you have inserted the box, change its type to 
Main, using the Type popup in the General (Box) section of the Box Inspector. 
Setting the type to Main indicates that this box contains the main content of a 
page. It also causes the box to be renamed main.
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Now type “Heading” inside the box. When you have done this, type Return to 
create a new paragraph and add some text, such as the following placeholder 
(Lorem Ipsum) text (snippet 1):

Nulla facilisi. Duis aliquet egestas purus.

Pellentesque eu est a nulla placerat dignissim. Morbi a enim 
in magna semper bibendum. Etiam scelerisque, nunc ac 
egestas consequat, odio nibh euismod nulla, eget auctor orci 
nibh vel nisi. Aliquam erat volutpat. Mauris vel neque sit 
amet nunc gravida congue sed sit amet purus. Quisque lacus 
quam, egestas ac tincidunt a, lacinia vel velit. Aenean facilisis 
nulla.

Maecenas nec urna et dolor dictum consequat. Phasellus eu 
iaculis sapien. Ut in lobortis eros, ut dignissim massa. 
Quisque non auctor urna, eget hendrerit nulla. Praesent libero 
leo, iaculis eu cursus at, molestie vitae urna.

To import this text, choose Text from the Insert menu, and import snippet 1 
from the Text folder that accompanies this tutorial. Import (or copy/paste) it a 
number of times, so that the page will scroll within Xway and when viewed in 
a browser.

Now click inside the first paragraph (“Heading”) and choose Heading 1 from 
the Type popup in the Paragraph Inspector.

When you’ve done this, switch to the Home page in the Site panel, and change 
“Heading” (the first paragraph in main) to “Home”. Next, switch to the News 
page and replace “Heading” with “News”. Then do the same on the 
remaining pages, replacing “Heading” with “About”, “Gallery”, and 
“Contact”.

Save the document, naming it Xway Menu.

Testing the menu

We can now test the menu. Choose Preview from the File menu so that you can 
view the site in a browser. You should be able to navigate to the different 



8 Creating a menu

pages by clicking on menu links, and the headings on each page should 
identify which page you are currently on.

If a link doesn’t work, go back to the master page and check that it has been 
set. Then preview again.

Now try shrinking the width of your browser window, and you should find 
that the menu is replaced by a hamburger menu when the window shrinks 
below a minimum width. The hamburger menu bar contains a hamburger 
icon at the top left. If you click on the hamburger icon, it will open a drop-
down menu containing links to the other site pages, and the hamburger icon 
will be replaced by a cross. Clicking on the cross closes the drop-down menu.

This shows how your menu will appear on mobile devices (phones or tablets) 
with narrow screens. Another way to test responsive layouts, without having 
to resize your browser window, is to view them in Safari and choose Enter 
Responsive Design Mode from the Develop menu. If you don’t see this menu in 
the menu bar, choose Settings from the Safari menu, click Advanced, and select 
Show features for web developers.

Styling the menu

By default, Xway creates a menu that contains black text on a white 
background. Let’s change this so that the menu contains white text on a black 
background.

Go back to the master page (click on it in the Site panel or choose Master Page 
from the Go menu). Option-click on the disclosure arrow next to it in the Site 
panel to open it (if it’s not already open), and click on the disclosure arrow 
next to the Site folder in the Site panel to close it.

Select the menu box (the parent box that contains the individual menu items) 
by clicking on it in the Page view or in the Site panel. If you look at the Box 
Inspector when a menu box is selected, you should see that it contains a Menu 
section with controls that allow you to change the menu’s style and settings. 
Some of these controls are duplicated elsewhere, but they are collected here 
for convenience.
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To get white text on a black background, choose White from the Text Color 
popup, then choose Black from the Background Color popup.

The next control in the Menu section is labelled Hover Text Color. This allows 
you to set a color that will be used when the mouse hovers over one of the 
links. Currently, this is the same as the normal text color, but we can change it 
so that text changes color when the mouse moves over it.

Change the hover text color to Red, and switch to Xway’s Web view by 
choosing Web Preview from the View menu, or by clicking on the Web Preview 
icon in the toolbar. Since we are on a master page—and master pages are not 
published—Xway will preview the first available site page instead of the 
master page, and temporarily show this page as the current page in the Site 
panel (the Home page icon is darkened). You should see that text in the menu 
changes to red when the mouse is moved over it. This also happens with the 
hamburger icon—as you can see if you reduce the width of the Web view by 
dragging the divider between it and the Inspector panel.

Let’s choose a more subtle change. Go back to the Page view. Then click on the 
Text Color popup (currently White) and choose Other from the bottom of the 
menu. Create a new color called Light Gray. This is a standard CSS color, so 
Xway will automatically set the Hex value. OK the dialog. Now choose White 
from the Hover Text Color popup.

To make this effect smoother, we can set a transition so that the color changes 
more gradually when the mouse is moved over it. With the menu box 
selected, type 0.5s in the Hover Transition field. This creates a half-second 
transition from light gray to white (and back).

Switch to Xway’s Web view to see how this looks.

Note: Don’t worry that menu links don’t work if you click on them in Xway’s Web 
view. This doesn’t follow links away from the current page.

Adjusting the breakpoint

Xway uses 768px as a default breakpoint—the point at which a menu is 
replaced by a hamburger menu. But we only have five items in our menu, and 
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we don’t need the breakpoint to be as wide as this. Staying in Xway’s Web 
view, reduce its width by dragging the divider between it and the Inspector 
panel. You will see that there is plenty of space left in the menu bar when it 
switches to a hamburger menu. Let’s try a smaller breakpoint. Go back to the 
Page view and type 400px in the Breakpoint field, then preview again in 
Xway’s Web view. You should find that this works fine. Using a smaller 
breakpoint (when possible) means that users can navigate your site on tablets 
and larger phones, without having to go through the extra step of opening a 
hamburger menu. Conversely, if you have a lot of items in a menu, you may 
need to use a larger breakpoint. If there isn’t room for all the items in a menu 
when you shrink Xway’s Web view, choose a larger breakpoint. If there’s 
plenty of room, try using a smaller breakpoint.

Changing the menu’s CSS position

You may have noticed that when you open the hamburger menu in Xway’s 
Web view (or in a browser) it pushes other content down the page as it opens. 
Perhaps it would be neater if the menu simply opened in front of the other 
content.

To fix this, go back to the Page view and change the menu’s CSS position from 
Relative to Absolute, using the Position popup in the Style section of the Box 
Inspector. Absolute items are positioned independently of other items, which 
makes them unsuitable for general layout—but this is precisely what we want 
in this case.

There is one drawback, which you may have noticed: the heading which was 
previously visible at the top of the main box has now disappeared behind the 
menu. We can fix that by adding some padding at the top of this box: 38px 
works in this case (select main on the master page and type 38px in the Top 
Padding field in the Padding section of the Box Inspector).

Switch to Xway’s Web view, and shrink its width until the menu is replaced by 
a hamburger menu. If you open this, you should find that it opens in front of 
the page content, without affecting it.
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Close the hamburger menu in Xway’s Web view, and scroll down the page. 
Notice that the menu scrolls out of view when you do this. If you’d rather it 
stayed at the top of the window (or screen on mobile devices) this is easily 
arranged. Go back to the Page view, select the menu, and change its position 
from Absolute to Fixed, using the Position popup in the Style section of the Box 
Inspector. Now, instead of being displayed at the top of the page (and scrolling 
when the page is scrolled) it is fixed to the top of the window, and the page 
content scrolls behind it. This happens in the Page view as well as the Web 
view.

One other tweak that we can make is to change the menu’s background color 
from opaque black to a partially transparent black. Select Other from the 
Background Color popup, type 0 (zero) in the Hex field, followed by 85% in the 
Opacity field, then tab out of the Opacity field and OK the dialog. Now, if you 
switch to the Web view and scroll the page, you should see that the page 
content is faintly visible behind the menu—but only when the full menu bar is 
shown (hamburger menus are always displayed with an opaque background).

Now preview the site in a browser, and test that everything works correctly. 
Save your document (call it Xway Menu). You can use the menu you’ve created 
in the following chapter.

Further options

See the Xway User Guide for more information on menus—there is a separate 
chapter with detailed information—and feel free to experiment with other 
options. You can change the font that is used, or the size of text within the 
menu, or the padding that is used within each menu item, or the horizontal 
space (margin) between menu items. You can set a hover background color, 
and choose whether to use rounded or square corners for this background. 
You can change the alignment of menu items within a menu, and you can 
change the alignment of the hamburger icon within a hamburger menu. You 
can also choose whether to animate the menu or have it display instantly (if a 
user has chosen Reduce Motion as an accessibility option it will always display 
instantly for them). If you’d like to keep the Home link in the hamburger 
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menu bar, so it is more easily accessible, you can select the Keep Home in Menu 
Bar checkbox. For other options, see the Xway User Guide.

Note: Mac users can choose Reduce Motion from the Accessibility/Display section of 
System Settings.
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Ambient menus

This chapter provides steps for adding a navigation menu to the Ambient and 
Ambient Light documents that are created by the Xway Tutorial. This assumes 
that you have already worked through the previous chapter (“Creating a 
menu”).

Adding a menu to the Ambient document

The page titles that we used in the previous chapter are identical with the 
page titles that are used by the Ambient document, so we can copy the menu 
we created and use it to replace the navigation bar in the Ambient document.

Open the Ambient document. If you haven’t worked through a recent version 
of the Xway Tutorial, or you didn’t keep a copy of the document you created, 
download the Ambient document from our website (choose Xway Resources 
from Xway’s Help menu, then click on Tutorials followed by Download the 
tutorial documents). When you’ve opened it, duplicate the document by 
choosing Duplicate from the File menu, and name the duplicate document 
Ambient 2. When you’ve done this, close the original Ambient document.

Close the current page of the new document by clicking on the disclosure 
arrow that is next to it in the Site panel, and switch to the master page (Master 
1) by clicking on it in the Site panel. Open this by Option-clicking on the 
disclosure arrow next to it.

We’re going to replace the navigation box: select it in the Site panel and choose 
Delete from the Edit menu (or press Backspace).

Now open the document you created in the previous tutorial, and copy the 
menu from the master page: select menu in the Site panel and choose Copy 
from the Edit menu (shortcut: ⌘C). Now switch back to the Ambient 2 
document and select the brand box before choosing Paste from the Edit menu 
(shortcut: ⌘V). This will paste the menu after brand (where the navigation box 
used to be)—although it won’t actually look like that in the Page view, 
because we set the menu box to have fixed position. I don’t think this works 
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too well with the current Ambient design, so let’s change it back to absolute 
position: go to the Box Inspector and choose Absolute (instead of Fixed) in the 
Position popup (in the Style section of the Box Inspector). Next, delete the Top 
offset (currently 0px) in the Offsets section of the Box Inspector. Now the menu 
is where the old navigation box used to be.

You might wonder what just happened. How does deleting the top offset of an 
item with absolute position cause it to move in this way? The answer (which 
you can also find in the Xway User Guide) is that absolute-positioned items 
which don’t have a vertical offset are vertically positioned according to where 
they would be in the flow if they had relative (or static) position: in this case, 
immediately after the brand box.

There is a third position option that is useful with menus. Xway has support 
for sticky position. This behaves like a combination of Relative and Fixed 
position: boxes with sticky position are relatively positioned (like other inflow 
boxes) until they reach a defined offset, at which point they become fixed to 
the viewport. Give the menu sticky position by choosing Sticky from the 
Position popup in the Style section of the Box Inspector. Now preview the page 
in a browser, and shrink the height of the browser window so that you can 
scroll the page upwards.

What you should find is that changing the menu position to sticky doesn’t 
seem to have made any difference to its scrolling behavior. This is because 
there is one significant difference between the behavior of fixed-position boxes 
and that of sticky boxes: fixed boxes remain fixed on screen when their parents 
scroll out of view, but sticky boxes remain within the bounds of their parents, 
and will scroll when the far edge of their parent catches up with them. In the 
case of a sticky-positioned box with a top offset of zero, this will stick to the 
top of the screen until the bottom edge of its parent (the header box in this 
case) catches up and pushes it out of view.

The way to fix this is to make the menu (or any other sticky box) be a direct 
child of the page div (called page-wrapper in this case). Select the menu on the 
master page and cut it from its current position (as a child of header), then 
select the header box and paste the menu back after it (so it is a child of page-
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wrapper). If you preview again, you should find that the menu sticks to the top 
of the screen when you scroll upwards. (The page div is always visible, unless 
there is absolute-positioned content outside its bounds.)

There is a slight difference between the background color of the menu box 
(Black 85%) and the background color of adjacent content (Charcoal). To fix 
this, select menu on the master page and choose Other from the Background 
Color popup in the Menu section of the Box Inspector. Enter Charcoal as the 
name of the new color, then enter 111111 (or just 1) in the Hex field, and 85% in 
the Opacity field (this will rename the color to Charcoal 85%).

The one thing that we still need to do is to set up the links, so they go to pages 
in our current document. Click on the Home menu item, go to the Link 
Inspector, and choose Home from the Page popup. Then press Tab to move to 
the next menu item (News), and choose News from the Page popup in the Link 
Inspector. Set up the links for About, Gallery, and Content in the same way.

Now preview in a browser. You should find that you have a working 
navigation menu. If you have problems with any of the links, go back and 
check that you set them up correctly. If you want to see how the site will look 
and behave on a mobile device, try shrinking the browser window, or use 
Safari’s responsive design mode (see above).

Now save the document. Name it Ambient 2 if you haven’t already done so.

This is what the Ambient 2 home page looks like in a desktop browser and on a 
phone:
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Adding a menu to the Ambient Light document

Let’s take a slightly different approach with the Ambient Light document. 
Instead of changing the menu to have absolute or sticky position, let’s adapt 
the design so that it works with a fixed-position menu.

Open the Ambient Light document—download it from our website if you 
haven’t recently created it with the Xway Tutorial. Now duplicate it by 
choosing Duplicate from the File menu, and name the duplicate document 
Ambient Light 2. Close the original Ambient Light document.

If the current page of the new document is not the master page, close it and 
switch to the master page (Master 1), then open this by Option-clicking on the 
disclosure arrow next to it in the Site panel. 

Now delete the navigation box and replace it with the menu. Select navigation 
in the Site panel and choose Delete from the Edit menu (or press Backspace). 
Now open the document you created in the first chapter of this tutorial 
(“Creating a menu”) and copy the menu from the master page: select menu in 
the Site panel and choose Copy from the Edit menu (shortcut: ⌘C). Switch 
back to the Ambient Light 2 document and select the brand box before choosing 
Paste from the Edit menu (shortcut: ⌘V). This will paste the menu box after 
brand (where the navigation box used to be)—although it won’t actually look 
like that in the Page view, because we set the menu box to have fixed position.
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This time we’re going to leave the menu box fixed to the top of the window, 
and adapt the rest of the page to fit around this. First, let’s remove the space 
above and below the page div (page-wrapper). Go to the Document: Pagediv 
Margins section of the Document Inspector and remove the top margin 
(currently 2vh). Next, go to the Document: Pagediv Dimensions section (just 
above) and change the minimum height from 96vh to 100vh.

Now we need to add some padding at the top of the page, to prevent the 
menu from overlapping other content (except when it is scrolled): select page-
wrapper on the master page (Master 1) and set Top Padding to be 38px (in the 
Padding section of the Box Inspector).

Perhaps the menu would look better if it didn’t extend across the entire width 
of a page, when this is wider than the page div. We can align the left edge of 
the menu with the left edge of the page div by removing its left offset: select 
the menu and delete the left offset (currently 0px) in the Offsets section of the 
Box Inspector. You might remember from earlier in this tutorial that absolute-
position boxes that don’t have a vertical offset are positioned vertically 
according to where they would be in the flow if they had relative (or static) 
position. That’s also true for horizontal offsets: an absolute-position or fixed-
position box that doesn’t have a horizontal offset is positioned horizontally 
according to where it would be if it had relative (or static) position.

We’re not quite there yet, because the menu is offset by padding that is 
applied to its parent, so we need to remove this. Select header in the Site panel 
and delete the left and right padding values in the Padding section of the Box 
Inspector (they’re not needed). Now the only thing we need to do is to set a 
maximum width that is the same width as the page div (page-wrapper): select 
the menu box again, and give it a maximum width of 960px in the Dimensions 
section of the Box Inspector.

We still need to set up the links, so they go to pages in the Ambient Light 2 
document. Click on the Home menu item on the master page, go to the Link 
Inspector, and choose Home from the Page popup. Then press Tab to move to 
the next menu item (News), and choose News from the Page popup in the Link 
Inspector. Set up the links for About, Gallery, and Content in the same way.
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Now preview in a browser. You should find that you have a working 
navigation menu. If you have problems with any of the links, go back and 
check that you set them up correctly. If you want to see how the site will look 
and behave on a mobile device, try shrinking the browser window, or use 
Safari’s responsive design mode.

Now save the document. Name it Ambient Light 2 if you haven’t already done 
so.

This is what the Ambient Light 2 home page looks like in a desktop browser 
and on a phone:
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Further information

Xway tutorials 

This is the second in a series of Xway tutorials, following the Xway Tutorial, 
which provides a general introduction to Xway. The next tutorial in this series 
is the Xway Flexbox Tutorial. This introduces Flexbox layout and shows how to 
use Flexbox in the Ambient 2 and Ambient Light 2 documents that are created 
by this tutorial. All these tutorials, and the documents they create, are 
available from our website.

There are also short tutorials (tagged “tutorial”) in the Xway discussion forum 
(see below).

Xway user guide

Xway comes with a detailed reference manual, which you can access by 
selecting Xway User Guide from Xway’s Help menu. This contains information 
on a wide range of topics, including a chapter on menus.

Xway discussion forum

Choose Support and Community from Xway’s Help menu to visit our Xway 
discussion forum. This contains Xway-related news and discussions, and is a 
good place to ask questions and get help from us and from other Xway users.

Xway resources

Choose Xway Resources from the Help menu to visit the Xway Resources 
section of our website. This contains links to the latest versions of this tutorial,  
along with other tutorials and completed tutorial documents. There are also 
other resources such as templates.
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